Office 2013 / 2016 / 2019 ProPlus Retail零售版密钥上架

获取确认id

微软系列
简要描述:

免打电话使用安装id(iid)换取确认id(cid)的api接口

如果服务器扛得住就不做请求限制,现在只有token错误10次,禁止ip一分钟。

点击最下面的按钮申请,我做了tg提醒,审核时效应该还行。

如果是用来做后端的话,期待挂个外链。

慢慢完善吧。

请求URL:
https://jihuo.ma/api/v1/mscid/

注意最后的/

请求方式:

POST

请求参数:
参数名 必选 类型 说明
token String 申请获取
iid String  
请求示例:
{
    "token": "",
    "iid": ""
}
返回示例:
{
    "status": 
    {
        "code":200,
        "message": "Success"
    },
    "value": 
    {
        "cid": ""
    }
}
错误代码:
code message
200 成功
406 长度错误或者不是json格式数据
500 服务器问题
python示例:
# -*- coding: utf-8 -*-

import requests


def test(_iid):
    _json = {
        'token': '我是token',
        'iid': _iid
    }
    r = requests.post("https://jihuo.ma/api/v1/mscid/", json=_json)
    if r.status_code == 200:
        return r.json()
    else:
        return False
    
    
if __name__ == '__main__':
    print(test('我是iid'))
易语言示例:

使用的精益模块

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 r, 文本型

r = 网页_访问S (“https://jihuo.ma/api/v1/mscid/”, 1, “{” + #引号 + “token” + #引号 + “:” + #引号 + “这里是token” + #引号 + “,” + #引号 + “iid” + #引号 + “:” + #引号 + “这里是安装id” + #引号 + “}”, , , “Content-Type: application/json;charset=utf-8”, )
输出调试文本 (r)
PHP示例:

感谢【shangguansi】提供php示例。

<?php
/**
 * Created by PhpStorm.
 * User:shangguansi
 * Date: 2020/4/16
 * Time: 18:44
 */

/**
 * curl请求
 * @param  String $url     请求地址
 * @param  Array  $data    请求参数
 * @param  Array  $header  请求header
 * @return String
 */
function Curl($url, $data, $header)
{
    //初始化
    $ch = curl_init();
    //设置抓取的url
    curl_setopt($ch, CURLOPT_URL, $url);
    // 添加头信息
    curl_setopt($ch, CURLOPT_HTTPHEADER, $header);
    //设置post方式提交
    curl_setopt($ch, CURLOPT_POST, true);
    // 设置post请求参数
    curl_setopt($ch, CURLOPT_POSTFIELDS, $data);
    //设置获取的信息以文件流的形式返回,而不是直接输出。
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
    curl_setopt($ch, CURLOPT_FOLLOWLOCATION, true);
    //设置头文件的信息作为数据流输出
    curl_setopt($ch, CURLOPT_HEADER, false);
    // CURLINFO_HEADER_OUT选项可以拿到请求头信息
    curl_setopt($ch, CURLINFO_HEADER_OUT, true);
    // 不验证SSL
    curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, FALSE);
    curl_setopt($ch, CURLOPT_SSL_VERIFYHOST, FALSE);
    $result = curl_exec($ch);
    if ($error = curl_error($ch)) {
        die($error);
    }
    curl_close($ch);
    return $result;
}
//安装id
$iid="这里填安装id";
$token="这里填安装你申请的token";
$url = 'https://jihuo.ma/api/v1/mscid/';
$data = array(
    'token' => "$token",
    'iid' => "$iid",
);
$jsonStr = json_encode($data);
$header = array(
    "Content-Type: application/json",
    "Content-Length: " . strlen($jsonStr) . "",
    "Accept: application/json",
);
$ret = Curl($url, $jsonStr, $header);

//打印输出的结果
echo "<pre>";
print_r($ret);
echo "</pre>";